Great news, unlockers! The iPhone Dev-Team has recently confirmed that an iOS 5 compatible version of ultrasn0w will launch in Cydia tomorrow, following a planned MobileSubstrate update.

The news came via a Twitter update from @MuscleNerd, which read:

will coordinate ultrasn0w iOS5 compatibility update to come out *after* a planned MobileSubstrate update tomorrow

However, as iDownloadBlog notes, the unlock tool will only be compatible with the following basebands: “01.59.00, 04.26.08, 05.11.07, 05.12.01, 05.13.04 and 06.15.00.” This means that you’ll have to preserve your baseband when updating to iOS 5 in order to unlock it with ultrasn0w.

If you’re wondering how to jailbreak iOS 5, we’ve got an article that explains the process in detail. Take a look at it, and let us know if you’re planning on unlocking via ultrasn0w in the comments.