The iOS 5.1.1 untethered jailbreak should launch very shortly. However, iDownloadBlog suggests this jailbreak isn’t necessarily for everyone and here’s why.

First, you should know that this jailbreak will only work with those iDevices using an A5 chip. These include the iPhone 4S, iPad 2, and new iPad. Second, it will only support iOS 5.1.1, Apple’s latest version of their mobile operating system. To make this process as smooth as possible, you are encouraged to download the iOS 5.1.1 firmware for each iDevice you wish to jailbreak.

Next, new iPad owners should update their iDevice to iOS 5.1.1 now even though the latest jailbreak isn’t yet available. The reason being that no previous jailbreak works with Apple’s newest tablet.

For those using an iPhone 4S or iPad 2, however, you have a choice to make depending on your situation. If your iDevice is jailbroken to iOS 5.0.1, it may be wise to wait until the next jailbreak release is available before installing the iOS update.  For those that recently purchased an iPhone 4S or iPad 2, however, and have iOS 5.1 preinstalled, you may want to jailbreak. In this case, download the iOS 5.1.1 firmware.

Keep in mind, iOS 5.1.1 is only an incremental release. Therefore, you may decide not to upgrade to the current release at all.

For those with an A4 iDevice (iPhone 4, iPod touch fourth generation), iDownloadBlog states:

Hopefully you’ve been proactive in saving your SHSH blobs, so you can always downgrade to previous firmware. iOS 5.1.1 is already jailbreakable (tethered) on iOS 5.1.1 for A4 devices, so chances are you may already have iOS 5.1.1 on your A5 device.

We’ll let you know when the new jailbreak is released. In the meantime, be sure to save your SHSH blobs.

Per pod2g’s iOS blog:

Here is the list of devices that are known to work for sure :

  • iPhone 3Gs
  • iPhone 4
  • iPhone 4 CDMA
  • iPhone 4S
  • iPad 1
  • iPad 2 Wifi
  • iPad 2 GSM
  • iPad 2 CDMA
  • iPad 3 Wifi
  • iPad 3 CDMA
  • iPod 3G
  • iPod 4G
Here is the list of devices that won’t be supported :
  • AppleTV 3
Remains to test (but that should work) :
  • iPad 2 Wifi, R2
  • iPad 3 Global
  • AppleTV 2

 

Are you planning on jailbreaking to iOS 5.1.1?

Source and Photo: iDownloadBlog