You are using an outdated browser. Please upgrade your browser to improve your experience.
Arkanoid vs Space Invaders

Defeat space invaders with brick breaking skill.

Two classic arcade games have been combined together into one all new challenge

Arkanoid vs Space Invaders

by SQUARE ENIX INC
watch trailer
Arkanoid vs Space Invaders
Arkanoid vs Space Invaders
$3.99 in the App Store

Two classic arcade games have been combined together into one all new challenge. Your goal is to use your best brick breaking skills to reflect the fire of the space invaders to try to take them out.

Watch the trailer

What is it about?

Two of the most iconic classic games ever made meet in Arkanoid vs Space Invaders!

App Details

Version
1.2
Rating
(71)
Size
305Mb
Genre
Arcade Action
Last updated
June 8, 2017
Release date
May 17, 2017
More info

App Screenshots

Arkanoid vs Space Invaders screenshot-0
Arkanoid vs Space Invaders screenshot-1
Arkanoid vs Space Invaders screenshot-2
Arkanoid vs Space Invaders screenshot-3
Arkanoid vs Space Invaders screenshot-4

App Store Description

Two of the most iconic classic games ever made meet in Arkanoid vs Space Invaders!

"There is just so much game here to enjoy..." - Destructoid 9/10
"... it's really worth putting your money where your mouth is and picking up this game." - TouchArcade 4.5/5

AUTHENTIC RETRO ARCADE GAMEPLAY
- Combines the exciting shoot ‘em up and block breaking gameplays in one game.
- Reflect the invaders bullets right back at them.
- Gather energy and trigger Attack Mode to destroy your enemies.

150 STAGES TO PLAY!
- Each level will test your skills and puzzle solving abilities.
- Experience over 20 different powers.
- Defeat huge 3D Invader bosses and save the galaxy.

NEED MORE?
- Unlock 40 different characters from the Taito legacy each with their own unique abilities (Shields, split ball, etc.)
- Hard Mode offers a new challenge for completionist players
- Compete on the leaderboards in ranked mode


Arkanoid vs Space Invaders is completely free of in-app purchases and requires IOS 8.0 or later.